System Requirements and Supported Platforms

DeltaWalker System Requirements

The hardware of most modern Macs and PCs packs plenty of power to run DeltaWalker. If in doubt, know that Deltopia recommends 2GB+ of RAM and 300MB+ of free disk space.

Supported Platforms

DeltaWalker runs on three of the world's most popular operating systems:

Apple Mac OS X:

  • 10.12 (Sierra), 10.11 (El Capitan), 10.10 (Yosemite), 10.9 (Mountain Lion), 10.7 (Lion), 10.6 (Snow Leopard), 10.5 (Leopard), 1.4.6 (Tiger - the carbon DeltaWalker build only)

Microsoft Windows®

  • Windows 10, 8, Windows 7, Windows Vista, Windows XP, Windows 2000

Linux®

  • Ubuntu, Fedora, RedHat, any Linux distro with GTK+ 2.2.1 or newer

DeltaWalker will likely run fine on other versions of the supported operating systems environments beyond the reference platforms we regularly test on. That applies in particular to the various Linux distros - as long as GTK+ 2.2.1 or newer and JRE 1.6 or newer are present, DeltaWalker should run fine.